Just ordered a DNA-800!

Want to talk about bass rigs? This is the folder for you.

Moderator: Bassmann1968

scottyn
Posts: 27
Joined: Sat Jul 18, 2015 9:12 pm

Re: Just ordered a DNA-800!

Postby scottyn » Thu Sep 29, 2016 6:07 pm

I have found myself leaving the EQ mostly flat on my 1350 and dialing in just a bit of shape and giving the low mid knob a slight boost in some rooms. Mixed with the DNA 2X10 cab it delivers a very punchy but full sound.

I have a mid size gigskinz mixer bag that I transport mine in. My 1350 fits in it just right. A little snug but I move all my own gear and it does the job.

JMSRocketBass
Posts: 11
Joined: Mon Mar 25, 2013 1:15 pm

Re: Just ordered a DNA-800!

Postby JMSRocketBass » Mon Oct 03, 2016 6:03 pm

Can I ask what power module is used is this amp and how does it compare to the ICE 700ASX?

User avatar
RipVanDan
Posts: 349
Joined: Tue Mar 30, 2010 7:47 am
Location: Duvall, WA

Re: Just ordered a DNA-800!

Postby RipVanDan » Tue Oct 04, 2016 3:32 pm

I'm sure you'll get a more technical answer but basically this is a power module that David Nordschow designed himself. It features a patented one cycle control loop technology design. He designed it to get away from the headroom problems that are inherent in the ICE modules that he used for the Eden WTX series when he still owned Eden. If you are not familiar with them, they use the ICE power modules. Those power modules put out decent power and clear sound, but had no headroom for peaks. So when you exceeded 500-watts with their 500-watt module, it clipped and did so with a very ugly sound.

David's new designs solve that problem and his DNA1350 will produce 1350 rms watts and 2700 watt peaks (that's the +3db). His DNA800 is rated at 800-watts rms and 1600 watts peak. So better in all aspects than the ICE power modules.

Dan
Rip Van Dan
Love those David Nordschow designs!
Amps: Eden WT500/800 (signature model!), Eden Nemesis RS400, Eden TN226
Cabs: DNS-410-8, DNS-210-8, two each Eden EX112-4
Basses: 1982 Fender Jazz (MIA), 2009 Rogue LX405 Pro (surprisingly good 5-string)

User avatar
Bassmann1968
Posts: 1065
Joined: Fri Mar 26, 2010 6:41 pm
Location: Germany
Contact:

Re: Just ordered a DNA-800!

Postby Bassmann1968 » Tue Oct 04, 2016 4:44 pm

Well, he did not design them himself, but they have been modified to his specs.
Armin

First european, first german, first old world and first multiple cab user :happy-smileygiantred:

1350, signed by David!
2xDNS112/8
1xDNS410/4

User avatar
rinos88
Posts: 469
Joined: Thu Sep 30, 2010 7:07 pm
Location: Earth

Re: Just ordered a DNA-800!

Postby rinos88 » Tue Oct 04, 2016 6:30 pm

His specs are flat out amazing because I've never been happier with my tone.

I guess I didn't realize that the 1350 was the RMS number and it maxed out at 2700.
That would explain why it absolutely smokes the 1500 watt Crown amp I was using before I got it. This thing has power to spare.
DNA 1350 and 410-4: Why settle for really good tone when you can have the best?

https://store.cdbaby.com/m/cd/warhammer1

kevor
Posts: 22
Joined: Wed Dec 29, 2010 6:37 pm
Contact:

Re: Just ordered a DNA-800!

Postby kevor » Sat Nov 12, 2016 12:51 am

New update:

I discovered the protect mode tonight. I was playing a gig with the trio I have been playing with at a local pub. This band is not particularly loud and I want trying out the new Sire M7 bass, which for the most part, is a fantastic bang for the buck. On the last two songs we got a little louder and the protect mode kept kicking in. Not sure why although I was driving the bass pretty hard and the M7 can cause clipping pretty easily. The master was at 12:00, eq flat, shape at 9:00, gain at 12:00. I have not been engaging the pad on the gain and I assume that was what finally kicked in the protect, although the electricity there is no the greatest either. This has not happened anywhere else I've used it. Anyone else run into this issue?

Another question, is anyone having any issues with the compressor? I notice there is an audible clip when it engages and if I am playing staccato notes then it clips on each note. It only seems to happen with my active basses, I don't notice it with my passive Lakland.

Also, some pics of the new bass. The Sire has a lot of versatility in tone between the humbuckers and the eq, so if I can settle the clipping issue it will become my live bass. A sweet deal for $700. UPS needs to do a much better job with shipping, though (see pic).
image.jpeg
image.jpeg
Kevin O'Reilly
"I'm so cutting edge I fell off"
DNA-800, 2 DNA 112C, Warwick Corvette ProLine 5 (flame maple), Lakland Skyline 44-64, BOSS GT-10B, Digitech Jamman Solo

User avatar
rinos88
Posts: 469
Joined: Thu Sep 30, 2010 7:07 pm
Location: Earth

Re: Just ordered a DNA-800!

Postby rinos88 » Mon Nov 14, 2016 7:28 am

Are you using a power conditioner? I'm wondering if it was sensing a voltage spike or something.
DNA 1350 and 410-4: Why settle for really good tone when you can have the best?

https://store.cdbaby.com/m/cd/warhammer1

kevor
Posts: 22
Joined: Wed Dec 29, 2010 6:37 pm
Contact:

Re: Just ordered a DNA-800!

Postby kevor » Mon Nov 14, 2016 9:33 am

rinos88,

I suspect it was either a voltage spike or an overheating issue as I was not able to recreate the issue at home using the same volume and bashing the bass to see if I could get the amp to trigger the protect mode. I did notice that when the protect mode would kick in there would only be one flash of the set level light and then it would click off - otherwise the set level light would not be going off. The gig was rather low volume, but the amp was directly underneath a heating pipe and it was pumping pretty hard.

My sense is the amp got beat up badly in shipping - apart from my compressor issue I've had some issues with some major hiss with the DI when recording - it hisses like mad and then I adjust the shape knob and it all goes away. It might be more sensitive than others (good thing I'm a counselor!).
Kevin O'Reilly
"I'm so cutting edge I fell off"
DNA-800, 2 DNA 112C, Warwick Corvette ProLine 5 (flame maple), Lakland Skyline 44-64, BOSS GT-10B, Digitech Jamman Solo

User avatar
rinos88
Posts: 469
Joined: Thu Sep 30, 2010 7:07 pm
Location: Earth

Re: Just ordered a DNA-800!

Postby rinos88 » Tue Nov 15, 2016 9:40 am

That is weird on the DI. I haven't experienced any issues at all with my 1350. Maybe you're right. It could've been severely abused during shipping and fondling.
DNA 1350 and 410-4: Why settle for really good tone when you can have the best?

https://store.cdbaby.com/m/cd/warhammer1


Return to “Amps and Speaker Cabs”

Who is online

Users browsing this forum: No registered users and 15 guests