Search found 340 matches

by TobiasMan
Fri Nov 08, 2019 1:46 pm
Forum: Player’s Lounge
Topic: New member in the DNA Artist page
Replies: 8
Views: 68

Re: New member in the DNA Artist page

Well deserved, man. Congrats! :clap:
by TobiasMan
Thu Nov 07, 2019 12:07 am
Forum: Player’s Lounge
Topic: New member in the DNA Artist page
Replies: 8
Views: 68

Re: New member in the DNA Artist page

Pretty select group you've joined there, Dan! 8-)

Congrats. You have had photos taken since they invented colour photos, right? :)
by TobiasMan
Sat Oct 05, 2019 7:31 pm
Forum: Amps and Speaker Cabs
Topic: 2 X DNS112 + DNS110
Replies: 16
Views: 4379

Re: 2 X DNS112 + DNS110

I understand there are some medications for that GAS.

Don't know if they are less expensive than buying the gear though. ;)
by TobiasMan
Sat Sep 28, 2019 3:57 pm
Forum: Player’s Lounge
Topic: Can I hide here?
Replies: 8
Views: 1735

Re: Can I hide here?

Yep, I'm here too, Paul. Started hanging out here well before the Garden's demise, but I too, mourn the loss of info, experience and resources, and community that resulted from that forum being dropped. Getting David's gear here in Canada is an issue. I don't think there are any active dealers and n...
by TobiasMan
Tue May 14, 2019 12:15 pm
Forum: Announcements
Topic: DNA tone settings
Replies: 8
Views: 7926

Re: DNA tone settings

Interesting findings firebass
by TobiasMan
Wed Dec 26, 2018 1:38 am
Forum: Player’s Lounge
Topic: Ho, Ho, Ho, 2018!
Replies: 3
Views: 3912

Re: Ho, Ho, Ho, 2018!

Same to you Dan. All the best to the Gene Pool Gang.
by TobiasMan
Tue Nov 27, 2018 7:30 pm
Forum: Amps and Speaker Cabs
Topic: contact DNA
Replies: 6
Views: 4726

Re: contact DNA

The DNA site lists Steve's Bass in Quebec as the only dealer in Canada, but while they have a fairly exhaustive list of bass amps they deal with, DNA is not on their list.

https://stevesmusic.com/en/amplifiers.html?cat=39

May be out of luck here in Canada.
by TobiasMan
Fri Aug 24, 2018 11:37 pm
Forum: Media Room
Topic: Eden WT500/800 into DNS410
Replies: 7
Views: 5833

Re: Eden WT500/800 into DNS410

Hmmm. . . no sound on the video here. Don't know, I seem to be missing sound on a number of YouTube vids, but not all. Are some using a different sound encoding?
by TobiasMan
Wed May 30, 2018 4:23 pm
Forum: Amps and Speaker Cabs
Topic: Because Cats...
Replies: 3
Views: 2974

Re: Because Cats...

Something to dissolve the glue residue?
by TobiasMan
Thu Sep 14, 2017 3:58 pm
Forum: Amps and Speaker Cabs
Topic: Buying in Canada
Replies: 21
Views: 15612

Re: Buying in Canada

I had a serious, long lasting problem with the Canadian "distributor" of David's Eden gear a number of years ago. I was changing out my speakers on my 4 Ohm 410 XLT to match my 8 Ohm 410 XST in order to bridge and get the most power from my amp. Ordered the replacement drivers, inquired at...

Go to advanced search